EN JP CN

Java Virtual Machine 要件

Java Virtual Machine 要件
このトピックの内容:

Windows

Windows では、Klocworkサーバー、分散解析、およびコマンドライン パッケージは、32 ビットまたは 64 ビット版 Java Virtual Machine、Java 8 Update 92 をバンドルしています。お使いのシステムは、このバージョンの Java の 要件を満たしている必要があります。Java は <klocwork_install_path>\_jvm\bin\ にインストールされます。インストールパッケージは、オペレーティングシステムが 32 ビットと 64 ビットのどちらであるかを自動的に検出します。

Linux

Linux では、32 ビット と 64 ビット版 Java のどちらにも独立したインストール パッケージがあります。お使いのオペレーティング システムに適したパッケージを選択してください。

Klocworkサーバー、分散解析、およびコマンドライン パッケージは、32 ビットまたは 64 ビット版 Java Virtual Machine、Java 8 Update 92 をバンドルしています。お使いのシステムが、適切なバージョンの Java の要件を満たしている必要があります。

Solaris

Solaris では、Klocworkサーバー、分散解析、およびコマンドラインパッケージは、32 ビット版 Java Virtual Machine、Java 7 Update 25 をバンドルしています。お使いのシステムが、適切なバージョンの Java の要件を満たしている必要があります。

Mac

Mac OS では、Klocworkは、システムで提供される Java Virtual Machine を利用します。 Klocwork Java 7 または Java 8 が必要です。以前のバージョンの Java がインストールされている状態でKlocworkをインストールしようとすると、「Java is not installed or version of Java is unsupported"」というエラーメッセージが表示されます。お使いのシステムが、適切なバージョンの Java の要件を満たしている必要があります。

AIX

Klocworkサーバーおよび分散解析パッケージは 32 ビット版 Java Virtual Machine、Java 8 Update 101 をバンドルしています。お使いのシステムが、適切なバージョンの Java の要件を満たしている必要があります。公開時点で IBM Java についてサポートされるシステム構成については、以下を参照してください。http://www.ibm.com/developerworks/java/jdk/aix/service.html

AIX の場合、32 ビット Java のみがサポートされます。AIX は他のプラットフォームと互換性がないため、projects_root ディレクトリを他のプラットフォームとの間でコピーしたり、移行したりすることはできません。

IDE プラグイン

Klocwork Desktop Java Plug-in for Eclipse および Desktop Java Plug-in for IntelliJ IDEA には、Java 7 以降が必要です。お使いの IDE が Oracle (Sun) Java の適切なバージョンで実行されていることを確認してください。