EN JP CN

Klocwork Desktop Plug-in for Visual Studio のヒントと方法

Klocwork Desktop Plug-in for Visual Studio のヒントと方法

Klocwork Desktop Plug-in for Visual Studio のヒントと方法

Klocwork Desktop Plug-in for Visual Studio のヒントと方法

Klocwork Desktop Plug-in for Visual Studio を使用するときにさまざまな設定をカスタマイズするのに役立つヒントと方法を示します。

指摘の表示方法の制御

以下の操作ができます。

  • デスクトップの指摘だけを表示するフィルター
  • アクティブファイルの指摘だけを表示するフィルター
  • 無視された指摘を表示するフィルター
  • 分類基準ファイル、 重要度、または チェッカーコードによるグループ化
注: 分類基準でグループ化し、同じ指摘が複数の分類基準で検出された場合、その指摘は該当する各分類基準で報告されます。同じ指摘が複数回報告される状況は、これ以外にはありません。

サーバーまたはシステム 指摘の検索

connected desktop (コネクテッドデスクトップ) の場合、サーバーまたはシステム指摘を調査または修正する必要がある場合があります。Klocwork Static Code Analysisそれぞれの検出された指摘およびサーバーの指摘に、指摘リストのアイコンを使用して、システムIDを割り振ります。

サーバーまたはシステム指摘を検索するには:

  1. 指摘について情報をできるだけ多く収集します。たとえば、指摘箇所があるファイル、指摘タイプ (ABV.GENERAL など)、行番号、オーナー (該当する場合)、重要度などです。
  2. [ローカルな指摘のみを表示] 設定がオフであることを確認します。
  3. [指摘] ウィンドウで、 [ファイル別にグループ化] [指摘コード別にグループ化] をクリックします。
  4. リスト内で関心のあるファイルを見つけ、展開します。
  5. 指摘タイプ (ABV.GENERAL など) を特定し、該当する行番号を持つ指摘タイプを選択します。
  6. 正しい指摘を見つけたことを確認するには、[Klocwork の指摘情報] ウィンドウで指摘のシステム ID をチェックします ([表示] > [その他のウィンドウ] > [Klocwork の指摘情報])。

無視した指摘の修復

以前に無視した指摘を修復するには、

  1. [Klocwork 指摘] ウィンドウで をクリックして無視した指摘を表示します。
  2. 指摘を復元するには、指摘を右クリックして [指摘を復元] を選択します。

チェッカーの有効化および無効化

Configuration Editor でチェッカーの有効/無効を切り替えます。これには、[Klocwork プロパティ] ダイアログからアクセスします。

ソリューションに C/C++ プロジェクトと C# プロジェクトの両方が含まれている場合、C/C++ 指摘は [C++ プロジェクト] タブ、C# 指摘は [C# プロジェクト] タブで構成します。各 Configuration Editor には、それぞれの言語に該当するチェッカーと分類基準だけが表示されます。C/C++ チェッカーと C# チェッカーの両方を含んでいる分類基準は、各 Configuration Editor に表示されますが、それぞれの言語に該当する指摘タイプだけが表示されます。

チェッカーの有効/無効を切り替えるには:

  1. ソリューションを右クリックして [Klocwork ソリューションプロパティ] を選択します。
  2. [C/C++ プロジェクト] タブまたは [C# プロジェクト] タブをクリックします。
  3. 必要に応じて、チェッカーを選択/選択解除します。チェッカーの詳細については、C および C++ チェッカーリファレンスC# チェッカーリファレンスを参照してください。
    ヒント: チェッカーは、[指摘] ウィンドウまたは左ガターで欠陥を右クリックして [チェッカーを無効化] を選択することにより、無効化することもできます。

    .

  4. [検索] フィールドを使用して、チェッカーをコード、タイトル、リファレンス、カテゴリ、または分類基準別に見つけます。

    変更内容が反映されるのは、次回解析を開始するときです。

    注意:
    [デフォルトに戻す] をクリックすると、工場出荷時のデフォルト設定がすべて復元されます。プロジェクトをサーバーに同期させると、サーバーのチェッカー構成設定に復元されます。

ライセンスサーバー設定の変更

ライセンスサーバーのホストとポートの情報は、通常はインストール時に設定されます。しかし、この情報が変更された場合は、[設定] ダイアログで更新する必要があります ([Klocwork] > [オプション] > [Klocwork] > [全般])。

Klocwork サーバーからの接続解除

サーバープロジェクトからプロジェクトまたはワークスペースの接続を解除するには:

  1. ソリューションを右クリックして [Klocwork ソリューションプロパティ] を選択します。
  2. [Klocwork プロジェクト] フィールドでドロップダウンメニューから空白エントリを選択し、[OK] をクリックします。

オンザフライ解析のカスタマイズまたは無効化

デフォルトでは、C/C++ プロジェクトのオンザフライ解析は有効です。オンザフライ解析は、C# プロジェクトではサポートされていません。解析は、ファイルを開いたときまたはファイルの編集中に一時停止したときに実行されます。そうではなく、ファイルの保存時に解析が行われるようにするには、次を実行します。

  1. [Klocwork] > [オプション] > [Klocwork] > [全般] を選択し、[解析] タブを選択します。
  2. [オンザフライ解析] ダイアログから、[ファイルの保存時] を選択します。

これで、オンザフライ解析がファイル保存時に実行されます。

また、ドキュメントを閉じたときに解析を継続するよう設定することができます。[解析] タブから、[ドキュメントを閉じたときにオンザフライ解析をキャンセルする] オプションを有効または無効にします。

オンザフライ解析を無効にするには:

  1. [Klocwork] > [オプション] > [Klocwork] > [全般] を選択し、[解析] タブを選択します。
  2. [オンザフライ解析] メニューから、[無効] を選択します。

解析を行うには、ソリューションを右クリックして [ソリューションの解析] を選択するか、プロジェクトを右クリックして [解析選択] を選択する必要があります。

エディターでのオンザフライ解析指摘マーカーの無効化/有効化

左余白アイコンを無効にするには、[Klocwork] > [オプション] > [Klocwork] > [全般] をクリックします。次に [表示] タブをクリックし、[指摘の左余白にマーカーを表示] をオフにします。追加マーカーとしての「アンダーライニング」も無効にできます。

検出された指摘の詳細の表示

検出された指摘の詳細については、[指摘] ウィンドウで指摘を選択し、[Klocwork] > [Windows] > [Klocwork 指摘] の順に選択します。

[Klocwork の指摘情報] ウィンドウには、問題 ID、ファイル、行、列、説明、重要度、およびオーナーという指摘プロパティに関するテキストレポートが表示されます。

指摘がデスクトッププロジェクトでのみ検出された場合、[問題 ID] フィールドには「デスクトップ」と表示されます。その指摘が統合ビルドで検出された場合は、システム ID が表示されます。サーバーの指摘は、指摘リストのアイコンによって表示されます。